ESXi “Dependency Error” requirement cannot be satisfied within the ImageProfile

Vmware ESXi update sırasında ssh üzerinden işlemleri gerçekleştirirken Image Profile driver uyumsuzluğu sebebiyle “requirement cannot be satisfied within the ImageProfile” hatası alınabilir. Bu durum ESXi üzerinde kurulu olan vib driverlar ile update edilmek istenen image’a ait profildeki uyumsuzluk sebebiyle gerçekleşmektedir.

Bu durumda ilgili viblerin kaldırılması gerekmektedir.

  • esxcli software vib list

Komutu ile ESXi üzerinde kurulu olan tüm viblerin listesini görebilir ve uyumsuzluğa neden olan vib ismini bulabilirsiniz.

Daha sonra ilgili vibleri kaldırmak için;

  • esxcli software vib remove -n “vib ismi”

komutu kullanılır.

İlgili tüm vibler kaldırılıp host reboot edildikten sonra update işlemi tamamlanabilir. Update edilecek versiyon ile birlikte ilgili driverlar yeniden yüklenecektir.

esxcli software profile update -d “update için kullanılacak dosya pathi” -p “profile number” komutunu kullanılarak update işlem yapılabilmektedir.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.

This site uses Akismet to reduce spam. Learn how your comment data is processed.